Print

Print


Surely CurrentProblem extends GPProblem, so you could rather cast into 
GPProblem and let dynamic binding select the over-ridden version of 
describe().

Denis

John Woodward a écrit :
> We can call this by the following line of code (In this case our
> problem is "BinPackingProblem"). So in KozaStatistics.finalStatistics
> we have
>
>        
> ((BinPackingProblem)state.evaluator.p_problem).describe(best_of_run[0],
> state, 0, statisticslog, Output.V_NO_GENERAL);
>
> However, I cannot see how to do this in general, i.e. currently I have
> to change the name of the problem explicitly.
> I would like to write something like
>
> ((CurrentProblem)state.evaluator.p_problem).describe(best_of_run[0],
> state, 0, statisticslog, Output.V_NO_GENERAL);
>

-- 
Denis Robilliard
Laboratoire d'Informatique du Littoral
50 rue Ferdinand Buisson
62100 CALAIS