Print

Print


I answer easy ones.
> I am also getting the following error within eclipse in the Add.Java file:
> public class Add extends GPNode....The serializable class Add does not
> declare a static final serialVersionUID field of type long
Add following line for "Add" class.

private static final long serialVersionUID = 1L;

> Could someone please help me to understand why this is occurring.
http://www.javapractices.com/Topic45.cjp

Eclipse has possibility define more varnings on or off, often warning level 
things are not severe mostly just anonying in big projects.
If you use several different JDK:s example both linux and windows 
enviroments to previous warning is more important than using only on JDK in 
enviroment that calculates default seralVersionUID right.

t. Harri

> Sincerely,
>
> Gerard
>
> I have not included the libraries list since I believe this is 
> unnecessary.