One item I've long contemplated is renaming VectorGene to just Gene. This would be more consistent with the naming scheme of the other vector individuals and species, and it'd be less to type.
I could do one of four things:
1. Directly rename VectorGene to Gene and let people start screaming.
2. Make Gene be a superclass of VectorGene (which would be empty and deprecated). This would require refactoring all references of VectorGene in GeneVectorIndividual and GeneVectorSpecies to refer to Gene instead. Eventually get rid of VectorGene.
3. Make Gene be a (for now) empty subclass of VectorGene and deprecate VectorGene. Eventually get rid of VectorGene. I don't know the consequences of using a deprecated superclass.
4. Keep things as they are and live with it.